Making your images presentable with Openlab

I know a lot of you use Adobe Photoshop to prepare your images before publication.

Did you know that you can do quite a lot of this in Openlab?  Let me give you an example. We will take the same three images we used last week and see if we can achieve the same result using Openlab, something that looks like this:-

Before we start I would just like to say that none of the tools I am using here make permanent changes to the raw data.

Ok, first let's open the file.

The images are 12 bit grayscale so first we will add a color look up table.

View the image that you want to add the look up table to.

You can select the color look up table from the Color table tool, you will find this on the toolbar on the left side of the image.

Alternatively you can access the color dialog and either make a look up table of your own or just enter the emission wavelength.  To do this go to the "Image" menu …"Colors".  The "Edit Image Colors" dialog appears.

Click the wavelength button and enter the emission wavelength.

Click "OK" on the "Edit Image Colors" dialog. Apply color to other layers as required.

When I have added the colors, I find that the images are still very dark so they could probably benefit from contrast enhancement.

Again first view the image, go to the "Image" menu "Contrast Enhancement".

The red line on the graph maps the pixels on the x axis to the colors on the y axis.

Click on the "Best Guess" and Openlab will work out the best distribution for you based on the brightest and darkest pixels in the image.

In the screenshot above I have used "Best Guess", there must be one or two bright pixels in the image and the majority of the image is not as bright as I would like it to be, so I will adjust the contrast manually. To adjust the contrast manually click and drag the red line or the "handle" on the red line. The handles are the small red squares you see along the line.

I think that looks a lot better. I would still recommend using the "Best Guess" whenever you can. Click "OK" then repeat this for the other layers as required.

The next step is to merge the images, at the moment we have three separate layers, for presentation we need to combine them. Select the layers that you want to merge in the Layers Manager.

Hold down the "command" key (this is the key that has the apple symbol on it) as you click to select more than one layer. Alternatively hold down the "shift" key, click on the top then the bottom layer, this will select all of the layers between these points.

Once selected click and drag the layers to the "New" button.

This will produce a merge of the three layers using an RGB merge. You can perform different types of merge (you will find these options under the "Layers" menu) but I find that the RGB merge is best for presentation purposes. When you perform an RGB merge the brightest component takes precedence in the merged image. The merged image is a new layer in the same file where the raw images are kept.  For further information on the different types of merge please consult the Openlab User Guide.

Before we export the image we need to add a scale bar.  Go to the "Image" menu … "Show/Hide Scale Bar".

If you don"t like the position or color of the bar go to the "Image" menu …"Scale Bar Options". Here you can change the position and color of the scale bar. There is also a checkbox to show the scale bars length.

If the scale bar looks the wrong length or is displaying the wrong units you need to check the spatial calibration of the images. Go to the "Image" menu …"Calibration", this will open the "Spatial Calibration" dialog.

Change the units as required, if you have saved calibrations you can access them by clicking on the small arrow. You can then select the required calibration from the list.

Click the "Calibrate" button to calibrate the image document.

Finally the last thing you need to do is to export the image as a TIFF file.

One thing to bear in mind, at this point I want a single TIFF file not a layered file; to save as single image/s from a multi layered file you need to use "Save as Multiple"

First select the layer in the Layers Manager.

Go to the "File" menu …"Save as Multiple"

Create a new folder if required by clicking on the "New Folder" button and also make sure that you select the location the file is to be saved to.

Enter a name and select the required format, I am going to use "TIFF for Publication".  By using this format the scale bar will be incorporated into the image data, so when the image is opened in other applications the scale bar will be visible. This format also creates a millions of colors image.

The name that you enter acts as the base name, this is the common name for all layers in the image document and acts as the name stem. Click on the "Naming" button to enter the "Naming Options".

I find that it is useful to "Append this text:" entering "tif". This will help the operating system to recognise the file if it is moved to the PC platform.

Also we only want to save the selected layer on this occasion so I have ticked the checkbox "Save selected layers only".

In the bottom of the dialog you will see an example of how the name is built up.

Once you are happy with the setup click "OK" to exit the "Naming Options" dialog and then click the "Save" button in the "Save" dialog.

As you can see if you open the image with another application (I have used "Preview" in Mac OS X) it looks the same and the scale bar has been included.

So why not try this when you next need to prepare images for publication, it's quick and easy to do – and you can stay in Openlab instead of moving to another software package.  Don't forget you can annotate your images in Openlab too – see the Openlab User Guide for details.  Hope this helps, see you next month!