Making movies in Volocity

Some time back I wrote a technical note on this subject, but I felt it would be worthwhile revisiting the subject and expand on the original version.

Before I start, be aware that this is only possible in the full version of Volocity. QuickTime and AVI  movies cannot be created using Volocity LE.

First let’s take a look at how to make a 2D movie.

At its simplest level you can take a folder of images.  Select the folder.

Then go to "File" > "Export"

As you can see from the screenshot above there are a number of file types to choose from. When you are making a movie on a PC you will have the choice of either AVI or QuickTime Movie (providing you have QuickTime installed). On the Mac you will not have the AVI option as this is only available on the PC.

If you click on the options button this will present the AVI or QuickTime movie options depending on what format you have selected.

As you can see from the "QuickTime Movie Options" dialog above you can set the compressor, depth, quality and timing of the movie file.

The "AVI Movie Options" dialog is similar, you can see this in the screenshot below.

Once you are happy with the settings click "OK" to exit the dialog and export the file.

For the next step we look at making a 2D movie from an image sequence. To do this you will need a movie sequence with more than one timepoint, it will not work if you only have a single timepoint.

Open the image sequence.

Switch to the Image view

As you can see above we are using the XYZ Planes view, if you have more than one Z slice then you can only export a QuickTime/AVI from this view if you are in the "Extended Focus" view. You will find this option under the "Image" menu.

 

Once in the "Extended Focus" view you can export the view as a QuickTime Movie or AVI Movie (Windows PC only).

Go to "File" > "Export".

So that’s pretty easy.  Let’s now expand on this and look at making a movie from the 3D view.

Click on the 3D tab to switch to the 3D view.

If you want to create a movie that simply advances through the timepoints you can go to "File" > "Export" to export the view as either a QuickTime Movie or AVI Movie (Windows PC only).

Alternatively you can make a movie sequence to rotate and zoom the view to create a more dynamic movie.

The first step is to make a new Movie Sequence.  Go to "Actions" > "Create New" …."Movie Sequence".

Drag the tasks from the left of the window into the main window, click and drag the ends of the tasks to define the required duration. Use the frame number scale on the top of the window as a guide to the length of time each task will last.

Put the tasks anywhere you like in the main window. If the tasks overlap they will run concurrently. Double click on each task in the work area to open the setup dialog.

For instance the 3D zoom task allows you to specify the start and end zoom level.

I am not going to go into the setup for all of the tasks in this technical note, for details on this please consult the Volocity User Guide.

The playback speed can be changed by clicking on the stop watch button and adjusting the slider control.

Just a quick look at the other buttons on the Movie sequence whilst we are here.

These are the playback buttons; step back, play and step forward.

These are the zoom controls that will allow you to scrutinize your movie.

Once you are happy with the Movie Sequence it is time to make the movie.

Go to "Sequence" > "Make Movie".

This will render the sequence and produce a folder of individual frames from which you can create a QuickTime or AVI movie. The folder will appear in the Volocity library.

To create the movie, first select the folder. Go to "File" > "Export" and select the format "QuickTime Movie" or "AVI Movie" as required.

I have come full circle here, as this is what I started by talking about. Just a final mention, you can also create QTVR Movies from the 3D view in Volocity. You will find this option under "3D" > "Create QTVR Movie".

Hope you have find this tip useful, see you next time!